The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> WEb link, Return point for a web link
jamesed
post Nov 21 2019, 09:34 AM
Post #1





Group: Members
Posts: 4
Joined: 21-November 19
Member No.: 27,046



I am using Linux Mint, and its chromium web browser. When I used Firefox; and after using a weblink to another page on my site (example: <A HREF="INSIDE HELP.HTML" STYLE="COLOR:ORANGE">HEARING</A>), it would always return to the departure line of the the first HTML page.
However, in chromium, it returns to the top of the first page.
Is there any way that I can correct this, to mimic Firefox's actions?
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 21 2019, 12:30 PM
Post #2


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,461
Joined: 9-August 06
Member No.: 6



QUOTE(jamesed @ Nov 21 2019, 03:34 PM) *

I am using Linux Mint, and its chromium web browser. When I used Firefox; and after using a weblink to another page on my site (example: <A HREF="INSIDE HELP.HTML" STYLE="COLOR:ORANGE">HEARING</A>), it would always return to the departure line of the the first HTML page.
However, in chromium, it returns to the top of the first page.
Is there any way that I can correct this, to mimic Firefox's actions?



Return? You mean if you use the back button? I don't know why that differs between browses and pages. I've wondered about that myself.

Not related, but your link is incorrect. URLs can't contain spaces. They must be URL encoded. Like so.
CODE
INSIDE%20HELP.HTML


But for many reasons it's better to avoid spaces in file names to begin with. You can use hyphen or underscore as a word separator instead.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
jamesed
post Nov 21 2019, 03:10 PM
Post #3





Group: Members
Posts: 4
Joined: 21-November 19
Member No.: 27,046



QUOTE(pandy @ Nov 21 2019, 12:30 PM) *

QUOTE(jamesed @ Nov 21 2019, 03:34 PM) *

I am using Linux Mint, and its chromium web browser. When I used Firefox; and after using a weblink to another page on my site (example: <A HREF="INSIDE HELP.HTML" STYLE="COLOR:ORANGE">HEARING</A>), it would always return to the departure line of the the first HTML page.
However, in chromium, it returns to the top of the first page.
Is there any way that I can correct this, to mimic Firefox's actions?



Return? You mean if you use the back button? I don't know why that differs between browses and pages. I've wondered about that myself.

Not related, but your link is incorrect. URLs can't contain spaces. They must be URL encoded. Like so.
CODE
INSIDE%20HELP.HTML


But for many reasons it's better to avoid spaces in file names to begin with. You can use hyphen or underscore as a word separator instead.


i inserted the %20, but it is still the same actin with the back button. Thanks for your help, though.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Christian J
post Nov 21 2019, 03:22 PM
Post #4


.
********

Group: WDG Moderators
Posts: 8,256
Joined: 10-August 06
Member No.: 7



QUOTE(jamesed @ Nov 21 2019, 03:34 PM) *

after using a weblink to another page on my site

Does this only happen on your own pages? If so, maybe someting else on your pages might be interfering.

(My Chromium-based Windows browser returns to the previous page's departure line, just like my other browsers.)
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 21 2019, 03:28 PM
Post #5


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,461
Joined: 9-August 06
Member No.: 6



QUOTE(jamesed @ Nov 21 2019, 09:10 PM) *

i inserted the %20, but it is still the same actin with the back button. Thanks for your help, though.


As I said, it doesn't have impact on your problems. But it could make your link not working. Many modern browsers mend mistakes like that, but probably not all of them and I have no idea how search engines handle it. So better do it right. Broken links are dead ends.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 21 2019, 03:30 PM
Post #6


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,461
Joined: 9-August 06
Member No.: 6



QUOTE(Christian J @ Nov 21 2019, 09:22 PM) *

QUOTE(jamesed @ Nov 21 2019, 03:34 PM) *

after using a weblink to another page on my site

Does this only happen on your own pages? If so, maybe someting else on your pages might be interfering.

(My Chromium-based Windows browser returns to the previous page's departure line, just like my other browsers.)


I've had browsers behave differently. And on some pages it doesn't work in any browser. I think they are dynamic pages. It irritates me and in fact I've planned to ask about it myself, but never got around to it.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
jamesed
post Nov 25 2019, 07:45 PM
Post #7





Group: Members
Posts: 4
Joined: 21-November 19
Member No.: 27,046



QUOTE(pandy @ Nov 21 2019, 03:30 PM) *

QUOTE(Christian J @ Nov 21 2019, 09:22 PM) *

QUOTE(jamesed @ Nov 21 2019, 03:34 PM) *

after using a weblink to another page on my site

Does this only happen on your own pages? If so, maybe someting else on your pages might be interfering.

(My Chromium-based Windows browser returns to the previous page's departure line, just like my other browsers.)


I've had browsers behave differently. And on some pages it doesn't work in any browser. I think they are dynamic pages. It irritates me and in fact I've planned to ask about it myself, but never got around to it.



I FOUND THE ANSWER TO BE, TO INSERT target="_blank" INTO THE HYPERLINK. THIS WILL EITHER OPEN A NEW TAB, OR A NEW WINDOW; DEPENDING ON HOW THE BROWSER IS CONFIGURED.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 26 2019, 11:04 AM
Post #8


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,461
Joined: 9-August 06
Member No.: 6



Well, that's a solution, but it's not the answer. wink.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
jamesed
post Nov 27 2019, 10:39 AM
Post #9





Group: Members
Posts: 4
Joined: 21-November 19
Member No.: 27,046



QUOTE(pandy @ Nov 26 2019, 11:04 AM) *

Well, that's a solution, but it's not the answer. wink.gif



AGREED!
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 12th December 2019 - 01:32 PM