The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> inet_aton and inet6_aton not working on local server
post May 10 2020, 03:22 AM
Post #1


Group: Members
Posts: 33
Joined: 5-March 20
Member No.: 27,220

When I run either the inet_aton or inet6_aton command on my local mysql server (Server version: 5.7.30-0ubuntu0.18.04.1 (Ubuntu)) I get the following error:

mysql> UPDATE download SET ip_address = inet6_aton(ADDRESS);
ERROR 1411 (HY000): Incorrect string value: '`test`.`download`.`ADDRESS`' for function inet6_aton

When I run the same command on my web host there's no problem. Both have exactly the same table structure and data. The data on the local server was imported from an export of the data on my web host. In both cases, the ADDRESS field is a varbinary(32). I've tried changing the local server to varbinary(16) and re-importing the data but got the same results. I've also restarted the mysql service but it made no difference.

Can someone please explain what is going on?

Thanks in advance

This post has been edited by larry78723: May 10 2020, 03:30 AM
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


- Lo-Fi Version Time is now: 3rd August 2021 - 11:13 PM