Printable Version of Topic

Click here to view this topic in its original format

HTMLHelp Forums _ Databases _ inet_aton and inet6_aton not working on local server

Posted by: larry78723 May 10 2020, 03:22 AM

When I run either the inet_aton or inet6_aton command on my local mysql server (Server version: 5.7.30-0ubuntu0.18.04.1 (Ubuntu)) I get the following error:

mysql> UPDATE download SET ip_address = inet6_aton(ADDRESS);
ERROR 1411 (HY000): Incorrect string value: '`test`.`download`.`ADDRESS`' for function inet6_aton

When I run the same command on my web host there's no problem. Both have exactly the same table structure and data. The data on the local server was imported from an export of the data on my web host. In both cases, the ADDRESS field is a varbinary(32). I've tried changing the local server to varbinary(16) and re-importing the data but got the same results. I've also restarted the mysql service but it made no difference.

Can someone please explain what is going on?

Thanks in advance

Powered by Invision Power Board (
© Invision Power Services (