The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Wordpress shortcut not working
Erik Emanuelli
post Jul 6 2021, 09:01 AM
Post #1





Group: Members
Posts: 2
Joined: 6-July 21
Member No.: 28,009



Hello everyone,
I don't know if the title is correct.

My issue is the following.

In this post:
https://erikemanuelli.com/on-page-seo/

if I click on the menu links within the post, example:
https://erikemanuelli.com/on-page-seo/#onpageseo

the reading jumps directly to that part of the article.

It's not happening here:
https://erikemanuelli.com/link-building/#linkquality

Is something incorrect in the HTML, or code, or anything else that you can see?

I really, really appreciate the help.
Thanks,
Erik
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Jul 6 2021, 11:50 AM
Post #2


🌟Computer says no🌟
********

Group: WDG Moderators
Posts: 19,777
Joined: 9-August 06
Member No.: 6



You've screwed up the link target IDs and included a hash sign in them.

CODE
<h2 id="#linkbuildingconcepts">


The hash only goes in the link to the target, not in the target name. The hash is what tells the browser it's dealing with a fragment identifier, i.e. that it should go look for "some_name" as the value of a name or id attribute in the same page. It won't find "#some_name".
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Erik Emanuelli
post Jul 7 2021, 06:53 AM
Post #3





Group: Members
Posts: 2
Joined: 6-July 21
Member No.: 28,009



QUOTE(pandy @ Jul 6 2021, 11:50 AM) *

You've screwed up the link target IDs and included a hash sign in them.

CODE
<h2 id="#linkbuildingconcepts">


The hash only goes in the link to the target, not in the target name. The hash is what tells the browser it's dealing with a fragment identifier, i.e. that it should go look for "some_name" as the value of a name or id attribute in the same page. It won't find "#some_name".


Thanks for taking the time to check the issue, Pandy.
I'm fixing it right now. biggrin.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Jul 7 2021, 07:37 AM
Post #4


🌟Computer says no🌟
********

Group: WDG Moderators
Posts: 19,777
Joined: 9-August 06
Member No.: 6



👍
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 27th July 2021 - 09:07 PM