The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

2 Pages V < 1 2  
Reply to this topicStart new topic
> Hosting problem, server is setup to prevent directory listing
aod1174
post Mar 13 2007, 09:56 AM
Post #21


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



Yes I have a control Panel. In fact I serched it for about 3 hours looking for anything I might have missed. I came across one of the sub, sub, sub options.. How nice of it to be so well displayed..lol

Ok heres my situation now. I got the directory tree to show just how I want it to, but for some reason when I click on the link, it doesn't download (Like it should).. So this is now my next problem to deal with.. Any suggestions here? heres the URL for some of the files, the files are in link form, again how they should be, but thier not really links (or so it seems).. You will see what I mean...

http://www.ricksfiles.com/CS/cstrike/
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Darin McGrew
post Mar 13 2007, 11:07 AM
Post #22


WDG Member
********

Group: Root Admin
Posts: 8,317
Joined: 4-August 06
From: Mountain View, CA
Member No.: 3



Maybe your host has blocked WAD files.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2007, 11:25 AM
Post #23


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



In that case they block .htaccess files too. Seems like an odd thing to do on a Windows server. mellow.gif
http://www.ricksfiles.com/CS/
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2007, 11:30 AM
Post #24


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



Hey, put a couple of files of known file types in there and see what happens. Throw in a faked file type too. Rename a text file something.pandy for instance.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
aod1174
post Mar 13 2007, 12:17 PM
Post #25


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



QUOTE(pandy @ Mar 13 2007, 12:30 PM) *

Hey, put a couple of files of known file types in there and see what happens. Throw in a faked file type too. Rename a text file something.pandy for instance.


there is a known file type in there. in cstike/gfx/env there are bmp files.. the "pandy" file is now up as well...

these are the options I'm given for folders "Red Web Browse Write Set Root"

if that helps at all
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2007, 12:31 PM
Post #26


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



No, that's a .pandy.txt file. I don't find any BMPs but I found some text files in s ub directory.

I was thinking the server maybe is configured to tell you the file can't be found for unknown file types. I don't know if that's common on Windows. A nix server wouldn't do that.

Anyway, if I'm right you need to tell the server the MIME type of those files. I have no idea about how to do that on IIS. Let's google some. ninja.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2007, 12:36 PM
Post #27


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



That was quickly done and it seems I guessed right. Lo and behold "IIS 6.0 does not serve unknown MIME types", http://support.microsoft.com/kb/326965 .
In the article there they talk about the server's main configuration, nothing that I can see about how a single user can do it. huh.gif

Oh dear. Could you zip the files? That would take care of it. Next time, go with a nix host. happy.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Christian J
post Mar 13 2007, 03:22 PM
Post #28


.
********

Group: WDG Moderators
Posts: 8,252
Joined: 10-August 06
Member No.: 7



Here's a BMP if someone's interested! smile.gif

http://www.ricksfiles.com/CS/cstrike/gfx/e...esert256_bk.bmp
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2007, 05:17 PM
Post #29


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



Not really. tongue.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
aod1174
post Mar 13 2007, 09:52 PM
Post #30


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



QUOTE(pandy @ Mar 13 2007, 01:36 PM) *

That was quickly done and it seems I guessed right. Lo and behold "IIS 6.0 does not serve unknown MIME types", http://support.microsoft.com/kb/326965 .
In the article there they talk about the server's main configuration, nothing that I can see about how a single user can do it. huh.gif

Oh dear. Could you zip the files? That would take care of it. Next time, go with a nix host. happy.gif


Well I could zip the files, but the problem with that is they files need to be in their original format.. See how it works is this.. I have 2 servers, the server in question and a gaming server. The client connects to the gaming server to play. If the client does not have the map, or any of the files the map uses, they start to download it from the gaming server. Seeing as it's a gaming server, the download takes forever. By adding a CVAR I can redirct the client to the server in question where they can download the needed files in seconds... The clients computer will not download a zip file and then extract it, so the files have to be in their oringial state...

So basicly what your saying is theres nothing I can do? Theres no way to accomplish what I'm trying to do?
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Peter1968
post Mar 13 2007, 11:31 PM
Post #31


Serious Coder
*****

Group: Members
Posts: 448
Joined: 23-September 06
Member No.: 213



Easy answer: switch to a Unix based server that doesn't care what a WAD file is and delivers it as intended. or where you can set up a .htaccess with

CODE

AddType application/x-doom wad     


Hard answer: somehow convince your host to associate WAD's in IIS's /etc/magic or /etc/mime.types file or however it's done, as MIME type application/x-doom which is how they've been registered.

Good luck.

This post has been edited by Peter1968: Mar 13 2007, 11:33 PM
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
aod1174
post Mar 13 2007, 11:50 PM
Post #32


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



QUOTE(Peter1968 @ Mar 14 2007, 12:31 AM) *

Easy answer: switch to a Unix based server that doesn't care what a WAD file is and delivers it as intended. or where you can set up a .htaccess with

CODE

AddType application/x-doom wad     


Hard answer: somehow convince your host to associate WAD's in IIS's /etc/magic or /etc/mime.types file or however it's done, as MIME type application/x-doom which is how they've been registered.

Good luck.



Would it just be easier if I told them to switch my server over to a Linux server? That seems like it would be easier then trying to convince them of anything...
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 14 2007, 03:51 AM
Post #33


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



Start wih informing them about that .htaccess isn't a configuration file on IIS. That should be useful for them. tongue.gif

See if you can find anything like HTTP Headers, File Types, MIME or Content-types in your CP. Does that host of yours have a FAQ?
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
aod1174
post Mar 14 2007, 01:47 PM
Post #34


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



QUOTE(pandy @ Mar 14 2007, 04:51 AM) *

Start wih informing them about that .htaccess isn't a configuration file on IIS. That should be useful for them. tongue.gif

See if you can find anything like HTTP Headers, File Types, MIME or Content-types in your CP. Does that host of yours have a FAQ?



This is all they really have on the FAQ that relates to my problem

"Can I configure MIME types on my Linux Hosting Account?

You can configure MIME types on your Linux hosting account using a .htaccess file. When you configure MIME types in your .htaccess file, you associate file types with a specific application or action.

For example:
AddType application/x-shockwave-flash swf

AddType specified you are adding a new mime type (file type).

application/x-shockwave-flash is the actual mime parameter specs.

swf is the extension of the file type."


It seems I have to switch it to a linux server
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 14 2007, 02:40 PM
Post #35


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



Yeah, ot make your host realize you are on an IIS server and either tell you how to do it or do it for you.

Is your host a reseller by any chance? I looked at your name servers and they belong to a company that seems to mainly sell reseller plans. Or maybe you've bought a reseller plan from them.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
aod1174
post Mar 14 2007, 02:45 PM
Post #36


Newbie
*

Group: Members
Posts: 13
Joined: 9-March 07
Member No.: 2,151



QUOTE(pandy @ Mar 14 2007, 03:40 PM) *

Yeah, ot make your host realize you are on an IIS server and either tell you how to do it or do it for you.

Is your host a reseller by any chance? I looked at your name servers and they belong to a company that seems to mainly sell reseller plans. Or maybe you've bought a reseller plan from them.



no clue if their a reseller... I'll make the call now...
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 14 2007, 02:59 PM
Post #37


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,448
Joined: 9-August 06
Member No.: 6



Nothing wrong with that in case they are. Just wondering because of the answer they gave you before.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

2 Pages V < 1 2
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 8th December 2019 - 05:04 AM