The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

> Some SSIs not working and no error generated
wkgorey
post Jul 1 2019, 09:52 AM
Post #1





Group: Members
Posts: 4
Joined: 1-July 19
Member No.: 26,921



SSI's on my index page work fine when it is found as the default page if I type estateagentsespana.com into browser address bar.

But if I type estateagentsespana.com/index.htm into the address bar, the SSIs are ignored. SSIs on other pages are also being ignored.

My htaccess:

QUOTE

<Files 403.shtml>
order allow,deny
allow from all
</Files>
AddType text/html .shtml
AddHandler server-parsed .html
AddHandler server-parsed .htm

<IfModule mod_rewrite.c>
RewriteEngine On

# redirect from non-www to www with https
RewriteCond %{HTTP_HOST} !^www\. [NC]
RewriteRule ^(.*)$ https://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

# redirect from http to https
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</IfModule>

Options -Indexes

ErrorDocument 404 /404.htm



This post has been edited by wkgorey: Jul 1 2019, 10:11 AM
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
 
Reply to this topicStart new topic
Replies
pandy
post Jul 1 2019, 10:49 AM
Post #2


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,435
Joined: 9-August 06
Member No.: 6



Looks alright to me. Standard method. unsure.gif

But I'm wondering about this bit.

CODE
<Files 403.shtml>
order allow,deny
allow from all
</Files>


Have you written that yourself? Have your site at some point been hacked? If you didn't put it there yourself, look for the mentioned php file.
https://security.stackexchange.com/question...-are-showing-up
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Posts in this topic


Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 20th November 2019 - 10:14 PM