Help - Search - Members - Calendar
Full Version: Popular Established WordPress Based Information Site with NO Title Tag (?)
HTMLHelp Forums > Web Authoring > Web Site Functionality
MrGPT
I built an extremely popular (in my niche) web site (WordPress based) and it's long established now (many years) Today I discovered (to my horror) when trying 'woorank'(.com) to analyze my site that I've been running all this time without any title tag (?) Below is my code (Ads Theme: Theme Header (header.php)) and I'm not good enough in php to figure out what the issue is.

I don't want to resort to hard coding my titles because it would be a mistake for every generated page to have the same title (I want the title to be generated by each page/post) Any help would be appreciated - Thanks!

CODE

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" <?php
if(wp_version() == '21') language_attributes(); ?>>

<head profile="http://gmpg.org/xfn/11">

       <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
       <title>
              <?php
              if(is_single() || is_page() || is_archive())
              {
                     wp_title('',true);
              }
              else
              {
                     bloginfo('name'); echo(' — '); bloginfo('description');
              }?>
       </title>

       <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->
       <meta name="description" content="GPT Sites and Tips - Work at Home and Get Paid Instantly with Free Paid Surveys at Get Paid To Sites"/>
       <meta name="keywords" content="get paid to, gpt, free, paid surveys, work at home, instant paypal"/>
       <meta property="og:type" content="website" />
MrGPT
Oh, and here's some additional info:

SITE: MrGPT.com

- Always curent to the latest release of WordPress.

- My theme is real old because I am trying to recreate a popular retro 'look' cool.gif


WAIT! Stop the Presses! Ok, I got to poking around and I just now discovered that my POSTS have titles... ...and I guess my home page doesn't have a title because I kept that 'PAGE title' blank when I authored that 'PAGE' (as not to mess with my cosmetics (oops, I guess I mostly solved my own issue)

Solved! Nevermind! Sorry!
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.