Help - Search - Members - Calendar
Full Version: EXTREME BEGINNER - Easy Web 10 - Can't Publish
HTMLHelp Forums > Web Authoring > General Web Design
xyzHollyxyz
I just bought Easy Web earlier today. I recently purchased a domain from qth hosting - domain is mansiononwheels.com (my little travel trailer). I want to make the most simple trip log for my trip to Alaska in a few months...

However, I can't get it to publish and I don't know how to fix the problem...

"Unable to connect to the remote host. Ensure you have an internet connection to your hosting provider before publishing your website."

Can you please help this novice?
Thanks!
pandy
Do you mean WebEasy? Afraid I don't know anything about that program.

It must have a built in FTP client tough since you can use it to upload your stuff. Are you sure you have entered your username and password correctly?
pandy
Well, you have uploaded something here.

http://mansiononwheels.com

Avanquest is the company that makes WebEasy, so WebEasy must have uploaded that. Rude of them to put their copyright on your pages.

Alaska sounds like fun. I'm envious. Hope you have a nice trip. smile.gif
xyzHollyxyz
OP here - I've spent the afternoon trying to figure this out. What I've found, and I again, don't know how to fix it, is that you have to add mansiononwheels a second time...

mansiononwheels.com/mansiononwheels

????

xyzHollyxyz
And another beginner question - is there an easy way for me (ultimate novice) to add something on my web page so that my friends can get email notifications when I update the page?
pandy
OK. Your HTML file is named index.html and that's good.
http://mansiononwheels.com/mansiononwheels/index.html

I don't know if you know this, but when you type the URL to a directory, for example http://mansiononwheels.com/mansiononwheels/ the file index.html is automatically loaded. It's a little more complicated than that, but that's all you need to know for now (the server actually looks through a list of possible file names and serves the first file on the list that exists).

Do you have a folder on your computer called "mansiononwheels"? I think what has happened is that you've uploaded the whole folder into your web root folder at the server. If you upload a folder it becomes a folder on the server too.

I don't know if WebEasy does everything automatically or if it gives you choices. If it does, upload only index.html to your web root.
xyzHollyxyz
QUOTE(pandy @ Mar 8 2017, 06:33 PM) *

OK. Your HTML file is named index.html and that's good.
http://mansiononwheels.com/mansiononwheels/index.html

I don't know if you know this, but when you type the URL to a directory, for example http://mansiononwheels.com/mansiononwheels/ the file index.html is automatically loaded. It's a little more complicated than that, but that's all you need to know for know (the server actually looks through a list of possible file names and serves the first file on the list that exists).

Do you have a folder on your computer called "mansiononwheels"? I think what has happened is that you've uploaded the whole folder into your web root folder at the server. If you upload a folder it becomes a folder on the server too.

I don't know if WebEasy does everything automatically or if it gives you choices. If it does, upload only index.html to your web root.


THANK YOU! I'm off to figure it out (hahahahaha)...
xyzHollyxyz
Looks like I did upload the entire folder.

Under the public_html folder, there is a mansiononwheels folder with an IMAGES folder and 4 other files.

Do I move EVERYTHING to the public_html folder and then delete the now empty mansiononwheels folder?

pandy
Yes, that should work.

QUOTE(xyzHollyxyz @ Mar 9 2017, 01:30 AM) *

And another beginner question - is there an easy way for me (ultimate novice) to add something on my web page so that my friends can get email notifications when I update the page?


Not with just HTML. That would require that you are comfortable with installing scripts. My advice it that you leave it for a bit until you've gotten your feet wet.


xyzHollyxyz
OP HERE. I deleted the subfolder mansiononwheels and moved all its files to public_html. Worked fine.

Then I made a change to the page, uploaded it, and the subfolder was recreated again...can you tell from these FTP screens what I'm doing wrong?

IPB Image
pandy
I'm guessing Initial Local Folder.

You have this.
CODE
...Documents\Web Easy\HTML

Do you have the folder that gets uploaded inside the HTML folder? If so set the path to the local folder to this.
CODE
...Documents\Web Easy\HTML\mansiononwheels
xyzHollyxyz
YES, there is that folder in my local folder! I'll go try to change!
THANKS!!

ON EDIT: That was it! Thank you so much.
pandy
You're welcome. Good luck now and watch out for bears. happy.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.