Help - Search - Members - Calendar
Full Version: Why are table rows/cell not expanding 100%
HTMLHelp Forums > Web Authoring > Cascading Style Sheets
CharlesEF
Hi All,

I have a downloads page on my website and the table row/cells did expand to 100%. The HTML and CSS have been validated and no errors found.

Now that I have a 23" wide screen monitor I have noticed that some tables rows/cells still expand to 100% while some don't. My monitor is set to 1920x1080. The page in question can be seen here. When you click on a title it will open to display the file information. The file information is the table rows/cells that don't expand to 100%. Some do expand correctly, click the 'EliteGroup' or 'Sony VAIO' titles to see what I mean by expanding to 100% width.

I never had this problem until I got this 23" monitor and you might not see the problem unless you use the same screen resolution as I do.

Can anyone tell me why this happens? Or, how do I force all tables rows/cells to expand to 100% width?


Thank you for any and all help,

Charles
CharlesEF
I forgot to say that the problem shows up with any screen resolution greater than 1280x1024
Christian J
QUOTE(CharlesEF @ Feb 24 2017, 03:22 AM) *

I have a downloads page on my website and the table row/cells did expand to 100%.

Are the table widths actually set to 100% anywhere? I can only see that their grandparents DIV.lineitem are.

QUOTE
I never had this problem until I got this 23" monitor and you might not see the problem unless you use the same screen resolution as I do.

It seems to show up if you zoom out as well.
CharlesEF
QUOTE(Christian J @ Feb 24 2017, 10:06 AM) *
Are the table widths actually set to 100% anywhere? I can only see that their grandparents DIV.lineitem are.
No, I thought that would be inherited from the DIV. Before I posted I tried to fix the problem by adding 'width: 100%;' to class 'detailstr' but that didn't work. In fact, the rule would show up in the browser inspector as over-ridden (red line through the rule). I never thought of adding the rule to the table class itself. Once I added the rule to the table class 't0' everything started working as it should.

QUOTE(Christian J @ Feb 24 2017, 10:06 AM) *
It seems to show up if you zoom out as well.
Adding 'width: 100%;' to the table class 't0' seems to have taken care of this problem also.


Thanks for the help,

Charles
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.