Help - Search - Members - Calendar
Full Version: Styling form input box problem...
HTMLHelp Forums > Web Authoring > Markup (HTML, XHTML, XML)
wickedsam

I'm trying to make my autoresponder's form
look more visually appealing, and have made
some modifications to their basic form.

Clearly I am doing something wrong because
now the form is no longer working.

The code they provided me, that works fine:

<form action="https://app.getresponse.com/add_subscriber.html" accept-charset="utf-8" method="post">
<input type="text" name="email"/><br/>
<input type="hidden" name="campaign_token" value="nREaL" />
<input type="hidden" name="thankyou_url" value="http://best-affiliate-training.com/machine"/>
<input type="hidden" name="start_day" value="0" />
<input type="submit" value="CLICK HERE for Free Instant Access »"/>
</form>

My modifications, which is not working:

<form action="https://app.getresponse.com/add_subscriber.html" accept-charset="utf-8" method="post">
<input type="text" name="" style="background: url(http://cdn2.iconfinder.com/data/icons/ledicons/email.png) no-repeat #ffffff; background-position: 391px 10px;" class="email" id="optinEmail" placeholder="Enter your best email..."><br>
<input type="hidden" name="campaign_token" value="nREaL">
<input type="hidden" name="thankyou_url" value="http://best-affiliate-training.com/machine">
<input type="hidden" name="start_day" value="0">
<input type="submit" value="CLICK HERE for Free Instant Access »">
</form>


My theory is that I've made some basic
HTML mistake on the input email box line:

<input type="text" name="" style="background: url(http://cdn2.iconfinder.com/data/icons/ledicons/email.png) no-repeat #ffffff; background-position: 391px 10px;" class="email" id="optinEmail" placeholder="Enter your best email...">


Any help is massively appreciated.



pandy
You've left the name attribute blank. And you've also positioned the icon far to the right of the input. happy.gif

The data that's collected by a form builds on name - value pairs. No name, no value.
wickedsam
You are 100% correct, well spotted!

The reason I didn't spot it is that the plugin I am using is for some reason stripping out the word "email" from name="email"... and I have no idea why!

Thanks for spotting it!

Now I go on a strange code hunt indeed!

If you have any ideas on my next move in hunting this down, I'd be rather grateful... but alas I fear this one is not forum advice fixable... : (
pandy
I don't know. What are you looking for?
wickedsam

1. I'm now trying to figure out where in this plugin the code is that is stripping out the "email" from the name="email" field.

frustrating.

2. On a related potential workaround:

Is there a way to define the placeholder="Enter your best email..." from a style sheet?

So that way ALL inputs with a certain class showed that as the placeholder?

Thanks
pandy
1. What is this plugin? A plugin for what? Why do you need it? Can't you just type the markup?

2. No.
wickedsam

The plugin was something that helped with the video background.

Problem is now fully solved. Not even sure what was causing the stripping out...

Beautiful squeeze page is now fully working!

Temporarily set up at the following link:
http://review-able.com/voptin/earn-upto-26...-secret-weapon/

Will be moving it to best-affiliate-training.com in the next 72 hours.

Many thanks for your help... sometimes you work on something for too long and need a fresh set of eyes... thanks for being that for me.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.