Help - Search - Members - Calendar
Full Version: Tables in IE
HTMLHelp Forums > Web Authoring > Markup (HTML, XHTML, XML)
railker
Had this posted in another forum elsewhere, but the responses to problems numbered in the 1s and 0s it seemed, so hoping I'll get a better response here.

Click Here for the site ...

I know my way around HTML fairly well, CSS a little bit, and the rest is all haphazard copy-paste-make-it-work Frankenstein sort of deals.

Anyhow. I got this page on a site I'm an admin for to work. Works great on my page, and no complaints from anyone thus far.

Until I get an email from someone who uses IE and they report they don't see an entire section of this webpage. Basically there's some text that's part of the HTML, then below that there's supposed to be a table with a search function enabled with the help of List.js.

The page just ends at the text right above the code for the table, no headers, no nothing, so I figure it's a problem with the <tr>, <td>, etc. coding, but don't know how or where.

Opened it up in my own version of IE and confirmed that it doesn't show up for me in IE, either.

Feel free to check out the page, and View Source, etc., I'm sure you're all capable of finding where the code ends. My only qualm with changing anything is I'm not sure what values the list.js needs to enable the search functionality, if that would change anything or not ... as you can see at the bottom of that, I half-removed the add/edit/remove functions that used to be in that JavaScript because I didn't require them, but removing all of them made the script non-functional, hence my hesitation.


Many thanks! Please feel free to ask for clarification or whatever you may need to know. =)
pandy
Fix the errors and your problem will be gone.
http://www.htmlhelp.com/cgi-bin/validate.cgi

You have two HTML documents in one. You are only supposed to have one doctype, one HTML, one BODY and so on. I think the direct reason that IE doesn't display the table is the malformed comments. HTML comments look as described below and no other way.

http://htmlhelp.com/reference/html40/structure.html#comments
railker
I'll give that a try in removing the extras, I just wrote up the code from start to finish and inserted it into the page -- it gets set up differently than most, as a build-it-yourself sort of site for the average user. I'm just an admin, I didn't choose the site, haha.

Went through with the validator as well and fixed all the comments, and a couple of HTML errors. Showing up properly now in my version of IE -- some of the 'errors' are rather bogus for someone who still prefers to use <font> sort of tags when you only want a specific word in a <tr> line in a certain format. I'm sure there's a CSS way to do it, but that's overly tedious at the moment, haha.

Thanks for the advice, never trusted automatic 'validators' until now. =) Good stuff
pandy
The table shows up in my old version of IE too, IE7.

QUOTE
Went through with the validator as well and fixed all the comments, and a couple of HTML errors. Showing up properly now in my version of IE -- some of the 'errors' are rather bogus for someone who still prefers to use <font> sort of tags when you only want a specific word in a <tr> line in a certain format. I'm sure there's a CSS way to do it, but that's overly tedious at the moment, haha.


It's a mistake to hang on to that, but if you still want to you can and you can validate too, but you must choose an appropriate doctype. You want HTML 4.01 Transitional rather than Strict and you don't want HTML5 at all (the doc you had embedded in the first one earlier was HTML5). Talking about that, the slashes you get errors for belong in XHTML, not HTML. wink.gif


QUOTE

Thanks for the advice, never trusted automatic 'validators' until now. =) Good stuff


Yay! smile.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.