Help - Search - Members - Calendar
Full Version: Image not displaying properly in IE
HTMLHelp Forums > Web Authoring > General Web Design
sbrad
This is not a website I built but it was handed to me as part of my employer's portfolio (I usually work with Joomla and WP).
I can't for the life of me figure out why the image on the index page is screwed up in IE but displays fine in Chrome and FF. Any help would be greatly appreciated. Here is the URL:
http://www.thestockalert.com
pandy
FWIW I think all images display in IE7 even if the layout breaks a little. Which image is it?

Nice colors! smile.gif
sbrad
QUOTE(pandy @ Feb 15 2012, 11:55 AM) *

FWIW I think all images display in IE7 even if the layout breaks a little. Which image is it?

Nice colors! smile.gif

Sorry. It shows up as pretty obvious on my end. It's the image that goes right under the newsletter signup spot.
banner-index-right-bottom.jpg

Here is a screenshot of what it looks like in IE9:
IPB Image
pandy
Yeah, that's what I see. I thought you meant it didn't display at all. That's what I meant with that the layout is broken in IE7.

I'll have a look. Meanwhile you can fix the validation errors. The first one causes browsers to be in quirks mode. Also, you must decide if you want to use HTML or XHTML and choose a doctype accordingly.
http://www.htmlhelp.com/cgi-bin/validate.c...s&input=yes
pandy
The table is broken. At several places, one of them where you have that image. I'm not sure how you meant it to be.
sbrad
QUOTE(pandy @ Feb 15 2012, 02:44 PM) *

The table is broken. At several places, one of them where you have that image. I'm not sure how you meant it to be.

Let me take a look at the table then. Wonder why it displays correctly in chrome and ff. hmmm...
pandy
Browsers try to be helpful and mend what's broken. But they do it differently.


This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.