Help - Search - Members - Calendar
Full Version: Problems in IE
HTMLHelp Forums > Web Authoring > General Web Design
dublah
Hi, I just finished my first website, and it seems to look fine in every program but Internet Explorer.
In IE, on Macs running Windows , there are a bunch of gray boxes and the image loads with scroll bars, and on PCs running windows, there is no gray, but the images still load with scroll bars.
You can check out the site here:
My website
I've also attached a picture a friend of mine captured for me since I can only access OSX at the moment.
IPB Image

Edit: I just added a scrolling="no" to the iframe script but I can't check IE to see if it worked.
pandy
Start with fixing the errors.
http://www.htmlhelp.com/cgi-bin/validate.c...s&input=yes
http://jigsaw.w3.org/css-validator/validat...g=1&lang=en

Use a doctype. Not only to be able to validate properly, but also because without one (or with the wrong one) all browsers will be in Quirks Mode, displaying the bugs of older versions.
http://hsivonen.iki.fi/doctype/

Chances are those two things will fix the problems. If not, please post again. smile.gif
Josh J
excl.gif I am Running Windows XP and using Internet Explorer 8 and I have no problems. There is no Scrollbar appearing. That being Said, I have noticed that you do not have a valid doctype tag. Here is The <HEAD> Section of your page.
CODE
<head>
<title>Lisa DuBois | Illustration Portfolio</title>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<style type="text/css">
<!--
#apDiv1 {
    position:absolute;
    left:119px;
    top:204px;
    width:182px;
    height:120px;
    z-index:1;
    visibility: hidden;
}
#apDiv2 {
    position:absolute;
    left:32px;
    top:492px;
    width:267px;
    height:180px;
    z-index:0;
}
body {
    background-image: url(website2.png);
    background-repeat: no-repeat;
}
#apDiv3 {
    position:absolute;
    left:32px;
    top:185px;
    width:266px;
    height:85px;
    z-index:1;
}
#apDiv {
    position:absolute;
    left:32px;
    top:294px;
    width:266px;
    height:166px;
    z-index:1;
}
#Table_01 tr td #apDiv {
    font-family: Arial, Helvetica, sans-serif;
}
#apDiv4 {    position:absolute;
    left:32px;
    top:294px;
    width:266px;
    height:166px;
    z-index:1;
}
#Table_01 tr td #apDiv2 {
    font-family: Trebuchet MS, Arial, Helvetica, sans-serif;
}
body,td,th {
    font-family: Helvetica;
    font-size: 14px;
    color: 424242;
}
a:link {
    color: 424242;
    text-decoration: none;
}
a:visited {
    text-decoration: none;
    color: 424242;
}
a:hover {
    text-decoration: none;
}
a:active {
    text-decoration: none;
}
-->
</style>
</head>
I would like to include that Most Macs do NOT run IE. They Run Either
  1. Mozilla FireFox
  2. Apple Safari
If the Problem Persists, Feel free to contact me at:josh@jwjwebdesign.com
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2014 Invision Power Services, Inc.