The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> HTML table warriors
russ
post Jun 1 2007, 10:36 AM
Post #1





Group: Members
Posts: 4
Joined: 1-June 07
Member No.: 2,970



I'm doing a website for a friend but I'm totally out of the mix in web design these days and have forgotten all of the basic stuff.

My problem at the moment is tables, for some reason the tr tags seem to be adding a small space on the table on IE, but it looks perfect in firefox. I have all cell paddings/borders/spacing set to zero. Anything I'm missing out?

I've thought about using CSS but I don't have the time to learn something new. Any help would be cool

I've just uploaded the site here for testing purposes whilst I'm getting it just right.

http://damnably.50webs.com/


Here's the code.
CODE
<html>
<head>
<title>DAMNABLY presents... news</title>
<style type="text/css">
body
{
        background-image: url('images/bg_pattern.gif');
        background-repeat: repeat;
        background-attachment: fixed;
    scrollbar-face-color:FFFFFF;
    scrollbar-highlight-color:FFFFFF;
    scrollbar-3dlight-color:6699cc;
    scrollbar-shadow-color:FFFFFF;
    scrollbar-darkshadow-color:6699cc;
    scrollbar-arrow-color:ffcc66;
    scrollbar-track-color:FFFFFF;
}
.title {
    font-family: Tahoma;
    font-size: 11px;
    color: 6699cc;
    font-weight: bold;
        text-transform: uppercase;
}
.text {
    font-family: Tahoma;
    font-size: 10px;
    color: 000000;
    font-weight: none;
    font-style: normal;
    text-decoration: none;
}
a {
    font-family: Tahoma;
    font-size: 10px;
    color: 6699cc;
    font-weight: bold;
    font-style: normal;
        text-decoration: none;

}
a:visited {
    font-family: Tahoma;
    font-size: 10px;
    color: 6699cc;
    font-weight: bold;
    font-style: normal;
        text-decoration: none;

}
a:hover {
    font-family: Tahoma;
    font-size: 10px;
    color: ffcc66;
    font-weight: bold;
    font-style: normal;
        text-decoration: none;
}
a.music {
    font-family: Tahoma;
    font-size: 10px;
    color: 6699cc;
    font-weight: none;
    font-style: normal;
        text-decoration: none;
}
a:visited.music {
    font-family: Tahoma;
    font-size: 10px;
    color: 6699cc;
    font-weight: none;
    font-style: normal;
        text-decoration: none;

}
a:hover.music {
    font-family: Tahoma;
    font-size: 10px;
    color: ffcc66;
    font-weight: none;
    font-style: normal;
        text-decoration: none;
}

</style>
<script type="text/JavaScript">
<!--
function MM_swapImgRestore() { //v3.0
  var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}

function MM_preloadImages() { //v3.0
  var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
    var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
    if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_findObj(n, d) { //v4.01
  var p,i,x;  if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
  if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
  for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
  if(!x && d.getElementById) x=d.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
  var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array;

for(i=0;i<(a.length-2);i+=3)
   if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src;

x.src=a[i+2];}
}
//-->
</script>

</head>

<body>
<center>

<table width=650 valign=top cellpadding=0 border=0 cellspacing=0>

<tr cellpadding=0 border=0 cellspacing=0>
<td valign=top width=650 cellpadding=0 border=0 cellspacing=0>
<img src="images/top.jpg">

</td>
</tr>

<tr cellpadding=0 border=0 cellspacing=0>
<td cellpadding=0 border=0 cellspacing=0 valign=top>
<img src="images/top_02.jpg">
</td></tr>

<tr cellpadding=0 border=0 cellspacing=0>
<td valign=top cellpadding=0 border=0 cellspacing=0>

<table cellpadding=0 border=0 cellspacing=0 valign=top>
<tr valign=top cellpadding=0 border=0 cellspacing=0>
<td><img src="images/top_03.jpg"></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('news','','images/hover_04.jpg',1)"><img src="images/top_04.jpg"

border=0 name=news></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('shows','','images/hover_05.jpg',1)"><img src="images/top_05.jpg"

border=0 name=shows></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('releases','','images/hover_06.jpg',1)"><img

src="images/top_06.jpg" border=0 name=releases></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('media','','images/hover_07.jpg',1)"><img src="images/top_07.jpg"

border=0 name=media></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('forum','','images/hover_08.jpg',1)"><img src="images/top_08.jpg"

border=0 name=forum></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('links','','images/hover_09.jpg',1)"><img src="images/top_09.jpg"

border=0 name=links></a></td>

<td><a href="#" onMouseOut="MM_swapImgRestore()"

onMouseOver="MM_swapImage('contact','','images/hover_10.jpg',1)"><img

src="images/top_10.jpg" border=0 name=contact></a></td>

<td><img src="images/top_11.jpg"></td></tr></table>

</td></tr>

<table cellpadding=0 border=0 cellspacing=0>
<tr cellpadding=0 border=0 cellspacing=0><td width=40 bgcolor=6699cc cellpadding=0 border=0

cellspacing=0></td>

<td width=570 cellpadding=2>


<div align=right><a href="#" class=music>Launch Music Player</a></div>
<font class=title>Some news</font>
<br><font class=text>Today there was some news about some stuff. Awesome, eh? Yeah I thought

so ya prick.
<BR>In other news I blew up a baby with a firework, set fire to my nan and ate out Jordan.
<br>Posted by <a href="mailto:george@damnably.com">George</a></font>


<p><font class=title>Some News</font>
<br><font class=text>Today there was some news about some stuff. Awesome, eh? Yeah I thought

so ya prick.
<BR>In other news I blew up a baby with a firework, set fire to my nan and ate out Jordan.
<br>Posted by <a href="mailto:george@damnably.com">George</a></font>

<p><font class=title>Some news</font>
<br><font class=text>Today there was some news about some stuff. Awesome, eh? Yeah I thought

so ya prick.
<BR>In other news I blew up a baby with a firework, set fire to my nan and ate out Jordan.
<br>Posted by <a href="mailto:george@damnably.com">George</a></font></td>

<td width=40 bgcolor=6699cc cellpadding=0 border=0 cellspacing=0></td>
</tr></table>

<tr cellpadding=0 border=0 cellspacing=0>
<td width=650 cellpadding=0 border=0 cellspacing=0><img src="images/bottom.jpg">
</td></tr></table>


</center>
</body>
</html>
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
russ
post Jun 1 2007, 10:59 AM
Post #2





Group: Members
Posts: 4
Joined: 1-June 07
Member No.: 2,970



Actually, I managed to get it all done barring the bottom one. It just won't shift.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Darin McGrew
post Jun 1 2007, 11:18 AM
Post #3


WDG Member
********

Group: Root Admin
Posts: 7,987
Joined: 4-August 06
From: Mountain View, CA
Member No.: 3



I recommend that you start by fixing the HTML errors and CSS errors reported by the online tools. Among other things, you've omitted the number-sign character in front of a lot of hex color codes (e.g., 6699cc should be #6699cc) and your table structure is broken in places.


--------------------
Darin McGrew
WDG Member since 1998
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
russ
post Jun 1 2007, 12:38 PM
Post #4





Group: Members
Posts: 4
Joined: 1-June 07
Member No.: 2,970



I've cleaned up some of the errors though I don't really know what to do in this case

"Error: required attribute ALT not specified"

Other than that I can't find any other errors.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
russ
post Jun 1 2007, 12:48 PM
Post #5





Group: Members
Posts: 4
Joined: 1-June 07
Member No.: 2,970



Completely fixed now. Thanks for the help and advice.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 23rd April 2014 - 11:56 AM