The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> receiving this /*]]>*/ xhtml1.0 strict error. pls help, xthml webpage not displaying properly
sugarv
post Dec 18 2008, 12:52 AM
Post #1





Group: Members
Posts: 5
Joined: 18-December 08
Member No.: 7,364



The site I'm using for my journal rencently fixed some stuff on their site.. and when I came back.. my page looks weird (navigation links) is done below instead of at the left and I received this error /*]]>*/ when I validated my xhtml strict 1.0

Validation Output: 5 Errors

1. Error Line 56, Column 2: marked section end not in marked section declaration.

/*]]>*/


2. Error Line 56, Column 7: XML Parsing Error: Sequence ']]>' not allowed in content.

/*]]>*/


3. Error Line 56, Column 2: XML Parsing Error: Sequence ']]>' not allowed in content.

/*]]>*/


4. Error Line 56, Column 2: XML Parsing Error: internal error.

/*]]>*/


5. Error Line 56, Column 2: XML Parsing Error: Extra content at the end of the document.

/*]]>*/



Please help me correct this and removed the error. It wasn't like that last week but sisnce the site that's hosting my journbal made some changes.. it affected my script..i thin, pls help again fix the error and what I need to do. Thanks.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Darin McGrew
post Dec 18 2008, 02:00 AM
Post #2


WDG Member
********

Group: Root Admin
Posts: 8,302
Joined: 4-August 06
From: Mountain View, CA
Member No.: 3



Can you provide the URL (address) of a document that demonstrates the problem?

Without seeing the actual document, I'm guessing that something's wrong with the
CODE
<script type="text/javascript">
/* <![CDATA[ */
// content of your Javascript goes here
/* ]]> */
</script>
that is often used to hide JavaScript from the validator. But I recommend putting the JavaScript in a separate file and using
CODE
<script src="filename.js" type="text/javascript"></script>
instead.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sugarv
post Dec 18 2008, 02:22 AM
Post #3





Group: Members
Posts: 5
Joined: 18-December 08
Member No.: 7,364



QUOTE(Darin McGrew @ Dec 18 2008, 03:00 PM) *

Can you provide the URL (address) of a document that demonstrates the problem?

Without seeing the actual document, I'm guessing that something's wrong with the
CODE
<script type="text/javascript">
/* <![CDATA[ */
// content of your Javascript goes here
/* ]]> */
</script>
that is often used to hide JavaScript from the validator. But I recommend putting the JavaScript in a separate file and using
CODE
<script src="filename.js" type="text/javascript"></script>
instead.




This is my site http://www.codexed.com/~skylark

the "navigate' link used to be on the left side as well.. and everything was alright then bur after my last post the site made changes and my journal looks crappy and received xhtml errors. pls help with xhtml strict1.0. Thank you.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Darin McGrew
post Dec 18 2008, 02:35 AM
Post #4


WDG Member
********

Group: Root Admin
Posts: 8,302
Joined: 4-August 06
From: Mountain View, CA
Member No.: 3



You've got
CODE
[CDATA[
...
/*]]>*/
rather than
CODE
/* <![CDATA[ */
...
/* ]]> */
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sugarv
post Dec 18 2008, 02:52 AM
Post #5





Group: Members
Posts: 5
Joined: 18-December 08
Member No.: 7,364



QUOTE(Darin McGrew @ Dec 18 2008, 03:35 PM) *

You've got
CODE
[CDATA[
...
/*]]>*/
rather than
CODE
/* <![CDATA[ */
...
/* ]]> */




I did what you've suggested and I want my page to show like that..cos it used to be like that. However, it used to validate Xhtml strict 1.0... now it's just transitional. I really wanted the page to validate as strict 1.0 because that was how it used to be... before the hosting fixed some bugs and character encodings. How can I make strict?

Sorry I'm being persistent. Thank you.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Frederiek
post Dec 18 2008, 03:24 AM
Post #6


Programming Fanatic
********

Group: Members
Posts: 5,146
Joined: 23-August 06
From: Europe
Member No.: 9



You still have one HTML error on line 56 for the ending comment.
http://www.htmlhelp.com/cgi-bin/validate.c...s&input=yes

That's because of the CSS error on line 26.
http://jigsaw.w3.org/css-validator/validat....com/%7Eskylark

Put the CDATA, coded as Darin told you to, at the beginning of your CSS. Take Darin's exemple of ccoding for javascript, the same goes for CSS.

BTW, you have two BODY declarations in your CSS. And, you need to start your CSS declarations with the @import.
See http://www.w3.org/TR/CSS21/cascade.html#at-import.

User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sugarv
post Dec 18 2008, 12:08 PM
Post #7





Group: Members
Posts: 5
Joined: 18-December 08
Member No.: 7,364



QUOTE(Frederiek @ Dec 18 2008, 04:24 PM) *

You still have one HTML error on line 56 for the ending comment.
http://www.htmlhelp.com/cgi-bin/validate.c...s&input=yes

That's because of the CSS error on line 26.
http://jigsaw.w3.org/css-validator/validat....com/%7Eskylark

Put the CDATA, coded as Darin told you to, at the beginning of your CSS. Take Darin's exemple of ccoding for javascript, the same goes for CSS.

BTW, you have two BODY declarations in your CSS. And, you need to start your CSS declarations with the @import.
See http://www.w3.org/TR/CSS21/cascade.html#at-import.



So I need to remove one ccs and another code ccs? I did put the CDATA already..not sure if it's in correct place.

And where do I need to put this-- > <script src="filename.js" type="text/javascript"></script>. What do I need to do about ccs declaration. I want to have my page validate xhtml strict 1.0

Looking for help again. Thanks for being patient.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sugarv
post Dec 18 2008, 12:28 PM
Post #8





Group: Members
Posts: 5
Joined: 18-December 08
Member No.: 7,364



This is my page http://www.codexed.com/~skylark

This is just some part of my my code. (on another layout that I've tried) Did I put everything to where they should be? I validated the page using part of this code and I get valid Transitional.. but I wanted Xhtml strict.


<style type="text/css">

/* <![CDATA[ */

@import "all.css"; /* just some basic formatting, no layout stuff */

body {
margin:0px 0px 0px 0px;
}

#leftcontent {
float:left;
width:67%;
background:#ccccff;
border-right:2px solid #ffccff;
border-bottom:2px solid #ffccff;
margin-right:15px;
padding-bottom:20px;
}

#rightcontent {
}

p,h1,pre {
margin:0px 30px 10px 30px;
}

h1 {
font-size:14px;
padding-top:10px;
}

#rightcontent p {
font-size:12px;
margin-left:0px;
}
/* ]]> */
</style>
</head>


<script src="filename.js" type="text/javascript"></script>

<body>
<div id="leftcontent">
<h1><a href="http://www.codexed.com/~skylark">Skylark</a></h1>
<hr />

<h1>[title]</h1>
<h1>[time "%A, %B %d, %Y @ %H:%M %p"]</h1>
<pre>

</pre>

<p>[body]</p>


This was the previous... and when I validate this using this one.... my xhtml strict 1.0 has error which was pointed at already. I need to remove the CCS?


<style type="text/css">
Body {font-family : Verdana, Arial, Helvetica, Sans-Serif; background-color : #ffccff; color : #000000; font-size : 10pt;}

A:link {color : #9966cc; font-weight : bold; text-decoration : none; background : none;}

A:active {color : #800080; font-weight : bold; text-decoration : none; background : none;}

A:visited {color : #FF0000; font-weight : bold; text-decoration : none; background : none;}

A:hover {color : #000000; font-weight : bold; text-decoration : underline; background : none;}
[CDATA[
@import "all.css"; /* just some basic formatting, no layout stuff */

body {
margin:0px 0px 0px 0px;
}

#leftcontent {
float:left;
width:67%;
background:#ccccff;
border-right:2px solid #ffccff;
border-bottom:2px solid #ffccff;
margin-right:15px;
padding-bottom:20px;
}

#rightcontent {
}

p,h1,pre {
margin:0px 30px 10px 30px;
}

h1 {
font-size:14px;
padding-top:10px;
}

#rightcontent p {
font-size:12px;
margin-left:0px;
}
/*]]>*/
</style>
</head>
<body>
<div id="leftcontent">
<h1><a href="http://www.codexed.com/~skylark">Skylark</a></h1>
<hr />

<h1>[title]</h1>
<h1>[time "%A, %B %d, %Y @ %H:%M %p"]</h1>
<pre>

</pre>

<p>[body]</p>

Thanks to whoever's going to respond and help once more.


User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Frederiek
post Dec 19 2008, 04:32 AM
Post #9


Programming Fanatic
********

Group: Members
Posts: 5,146
Joined: 23-August 06
From: Europe
Member No.: 9



In the page at the url you posted, I see:

<style type="text/css">
/*some CSS declarations*/
[CDATA[
@import...
/*more CSS declarations*/
/*]]>*/
</style>

Obviously, the CDATA is wrongly coded and in the wrong place here.

The code snippit you posted above, seems ok to me.
Just try to validate the page that contains that code, in both the HTML and CSS validators.

Read around the HTML reference and CSS reference on this site (links to both on this page), to get a clear understanding.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 15th July 2019 - 07:41 PM