The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Would it be unadvisable to..., (Pre loading photo questions)
tharpdevenport
post Mar 12 2008, 04:09 PM
Post #1


Advanced Member
****

Group: Members
Posts: 201
Joined: 25-October 06
Member No.: 571



I'm using a pre-made JavaScript script on a new site I am constructing that pre loads the JPGs I got there. Herein lies the problem:

I use a jump to feature. Here is my issue, and then after that the part I am looking to find out if it's ill advised:

ISSUE:
On one initial page there are links to seperat pages A HREF=/example.html#JUMPTO (quotations removed for the examples)
But there are more than just a couple pics on each page; i'm not taling a lot, but rather somewhere between 10 to 25 and when they load, you're not longer exactly at the A NAME=JUMPTO part anymore.


ILL ADVISED?
I thought I'd correct this by adding the JavaScript and having all the images pre load first, but that didn't solve it, so here is the part I am asking you all about:
Would it be ill advised to have all the images pre loaded with that script on the initial page? That way they are all ready in the cache and they should be loaded and the jump to should work properly.

Catch is, there are -- with all three pages -- 67 images total, with possibly another dozen to be included much later on (and that will be ALL of them for those three pages -- no more additions).


They're all in JPGs and not large images. The largest photos, probably a dozen to 20 of them, are 533 x 359, the rest are probably about 25% smaller (a handful more so).
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2008, 05:38 AM
Post #2


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,402
Joined: 9-August 06
Member No.: 6



I think the question rather is why the page moves when the images load. Do you use the width and height attributes in the image tags? Can we see? wub.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
tharpdevenport
post Mar 13 2008, 02:08 PM
Post #3


Advanced Member
****

Group: Members
Posts: 201
Joined: 25-October 06
Member No.: 571



Well, as a plain page it doesn't move, but when you add images, it does. You see, it initially goes right where it's supposed to, but the amount of images (359 in height for some, as I noted) just makes the page longer, so it gets pushed away from it's spot.

I'm trying to keep the site under wraps for now.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Darin McGrew
post Mar 13 2008, 02:39 PM
Post #4


WDG Member
********

Group: Root Admin
Posts: 8,316
Joined: 4-August 06
From: Mountain View, CA
Member No.: 3



Without seeing the page, my guess is the same as pandy's guess. Add the height and width attributes to all the img elements so the browser can size them before they've been downloaded.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2008, 02:42 PM
Post #5


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,402
Joined: 9-August 06
Member No.: 6



So upload a "fake" page with blah blah text and other images. As long as the HTML is the same... Also, you didn't answer my question. Do you use the width and height attributes in the image tags?
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Mar 13 2008, 02:43 PM
Post #6


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,402
Joined: 9-August 06
Member No.: 6



Oops! This time Darin was quicker. laugh.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
tharpdevenport
post May 22 2008, 02:43 PM
Post #7


Advanced Member
****

Group: Members
Posts: 201
Joined: 25-October 06
Member No.: 571



Since then, I added the height and width to all the images, but it still doesn't get it dead on, but closer; sometimes just one away. I can PM the link, but I don't want to post it as it's a site I plan to premiere early June and it's not all constructed.

Now what? The height & width didn't fix it.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 17th October 2019 - 12:24 AM