The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> HTTPD service wont start
sanoj96
post Jul 19 2015, 05:14 PM
Post #1


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



Hello,

I am kinda new to Linux (centos), and i am trying to install apache on my linux terminal server. But the service HTTPD wont start.
Here is a log of journalctl -xn. If there is someone out there that can help me, please do smile.gif

CODE
[root@localhost ~]# journalctl -xn
-- Logs begin at sø. 2015-07-19 23:55:56 CEST, end at ma. 2015-07-20 00:09:32 CEST. --
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992295 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992304 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992309 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992316 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
juli 20 00:09:32 localhost.apilix systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
juli 20 00:09:32 localhost.apilix kill[2661]: kill: cannot find process ""
juli 20 00:09:32 localhost.apilix systemd[1]: httpd.service: control process exited, code=exited status=1
juli 20 00:09:32 localhost.apilix systemd[1]: Failed to start The Apache HTTP Server.
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit httpd.service has failed.
--
-- The result is failed.
juli 20 00:09:32 localhost.apilix systemd[1]: Unit httpd.service entered failed state.



Thanks
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 01:19 PM
Post #2


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



I am just reposting some info i got on another forum so if someone else got the same problem they might get a solution

here is what someone sayd:


juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992295 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 19 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992304 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 20 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992309 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 21 will probably never match because it overlaps an earlier A
juli 20 00:09:32 localhost.apilix httpd[2659]: [Mon Jul 20 00:09:31.992316 2015] [alias:warn] [pid 2659] AH00671: The Alias directive in /etc/httpd/conf.d/welcome.conf at line 22 will probably never match because it overlaps an earlier A


Have a look at the file mentioned - is there something wrong with those lines?

juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80


HTTPD can't start there's already something using tcp/80 - are you trying to start Apache when it's already running?
Also are you starting httpd as root?
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Jul 20 2015, 02:11 PM
Post #3


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 17,767
Joined: 9-August 06
Member No.: 6



Thank you for adding that information. smile.gif

Sorry no one here seems to be able to help. I've never run a server on Linux. I helped maintain one for a while, from a distance, but I wasn't the one who did the heavy stuff.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Frederiek
post Jul 20 2015, 04:24 PM
Post #4


Programming Fanatic
********

Group: Members
Posts: 5,146
Joined: 23-August 06
From: Europe
Member No.: 9



All I did was search for "install apache centos" on Google, which resulted, among others, to http://www.centos.org/docs/5/html/Cluster_...nshttpd-CA.html .

I hope that helps, as I know nothing about Linux.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:42 PM
Post #5


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



Ok, i got it running afhter a while, i reinstalled apache and set it up on new.

I only got one problem now...

Well ok i have cheked and done allot, i finaly got it up and running,
Now the only thing is that i cant get it public, like i cant acces the url/ip from my web browser. How can i do that, I am using CentOs 7, and i have opened the ports in the firewall using the following command
CODE
firewall-cmd --permanent --zone=<zone> --add-port=8080-8080/tcp
as showen on the image's
IPB Image

IPB Image,
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:43 PM
Post #6


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



Image shows wrong, It is enabled not disabled.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:50 PM
Post #7


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



Reply from centos forums:

You need to run firewall-cmd twice, once with --permanent and once without it.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:51 PM
Post #8


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



When that is done you will need to firewall-cmd --reload and try connect on new. (This dident work for me since i have already done that...)
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:55 PM
Post #9


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



I did some service check to see if the firewalld was running i ran this command
CODE
service firewalld status


IPB Image

I asked on the centos forums if they knew if this is ok or if i need to do something here since it shows red.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 04:59 PM
Post #10


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



Ill just post the url to the centos forums so you guys can read it there smile.gif no need for me to spam/bump my post.

https://www.centos.org/forums/viewtopic.php...=226047#p226047

This post has been edited by sanoj96: Jul 20 2015, 04:59 PM
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
sanoj96
post Jul 20 2015, 05:05 PM
Post #11


Member
***

Group: Members
Posts: 98
Joined: 18-September 12
Member No.: 17,803



I have fixed it now! it seems like the zone was wrong. it is now fixed. used this command to fix it firewall-cmd --set-default-zone=NameOfZone
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
imort
post Jun 18 2016, 07:28 AM
Post #12





Group: Members
Posts: 7
Joined: 18-June 16
Member No.: 24,338



QUOTE(sanoj96 @ Jul 20 2015, 04:14 AM) *

Hello,

I am kinda new to Linux (centos), and i am trying to install apache on my linux terminal server. But the service HTTPD wont start.
juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
[/code]


Hey

Take a look at the quote above.
It means that some other process is already using the port 80 on your server, that's why Apache can't start.
Apache can't use already occupied port.

You need to use another port by changing the 'Listen' directive in the httpd.conf file as a dirty hack or find out which process is using port first.
You can check for the processes using the 'netstat' utility: netstat -lt

If you'll have any other questions please feel free to ask.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
imort
post Jun 18 2016, 07:28 AM
Post #13





Group: Members
Posts: 7
Joined: 18-June 16
Member No.: 24,338



QUOTE(sanoj96 @ Jul 20 2015, 04:14 AM) *

Hello,

I am kinda new to Linux (centos), and i am trying to install apache on my linux terminal server. But the service HTTPD wont start.
juli 20 00:09:32 localhost.apilix httpd[2659]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
[/code]


Hey

Take a look at the quote above.
It means that some other process is already using the port 80 on your server, that's why Apache can't start.
Apache can't use already occupied port.

You need to use another port by changing the 'Listen' directive in the httpd.conf file as a dirty hack or find out which process is using port first.
You can check for the processes using the 'netstat' utility: netstat -lt

If you'll have any other questions please feel free to ask.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 21st November 2017 - 02:28 PM