The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Audio Autoplay not working in FF or IE
JeffLeites
post Mar 28 2019, 12:17 AM
Post #1





Group: Members
Posts: 9
Joined: 21-September 13
Member No.: 19,767



For many years when my web page was opened it would play a short .wav file. I just noticed that it no longer plays using the FireFox or Internet Explorer browser, but it does work using the Edge browser.

In order to isolate the problem, and make testing easy, I made a small html file whose only purpose is to play the .wav file when opened. Same results, it only works with Edge.

I'm using the Audio element with autoplay. In testing, I found if I use "controls" it will work in FF and Edge, but not IE.

This works with Edge, but not FF or IE:

<!DOCTYPE html>
<html>
<body>

<audio autoplay src= "IndexAudio/MrMotoLoop.wav"> </audio>

</body>
</html>

This works with Edge and FF, but returns an "Invalid Source" message in IE:

<!DOCTYPE html>
<html>
<body>

<audio controls src= "IndexAudio/MrMotoLoop.wav"> </audio>

</body>
</html>

How do I get it to work again?









User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Christian J
post Mar 28 2019, 05:06 AM
Post #2


.
********

Group: WDG Moderators
Posts: 8,238
Joined: 10-August 06
Member No.: 7



This seems to be an intentional change in browsers. See

https://hacks.mozilla.org/2019/02/firefox-6...ideo-and-audio/

https://developers.google.com/web/updates/2...-policy-changes

User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
JeffLeites
post Mar 28 2019, 09:23 AM
Post #3





Group: Members
Posts: 9
Joined: 21-September 13
Member No.: 19,767



Thanks for the reply. I'll look into this later but I just found something interesting. I was using my notebook computer this morning and tried opening my web page... the autoplay worked, both in FF and IE. I thought maybe after rebooting it would work on my desktop, but it's still not working there.

Anyone wanting to try it, it's http://www.jeffreyleites.com
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Christian J
post Mar 28 2019, 11:51 AM
Post #4


.
********

Group: WDG Moderators
Posts: 8,238
Joined: 10-August 06
Member No.: 7



QUOTE(JeffLeites @ Mar 28 2019, 03:23 PM) *

I just found something interesting. I was using my notebook computer this morning and tried opening my web page... the autoplay worked, both in FF and IE. I thought maybe after rebooting it would work on my desktop, but it's still not working there.

Anyone wanting to try it, it's http://www.jeffreyleites.com

Hmm, seems it still works in my FF66 as well. Though there is a setting in about:preferences#privacy for blocking web sites from automatically playing sounds, it wasn't enabled in my browser. According to https://support.mozilla.org/en-US/kb/block-autoplay "The Block Autoplay feature will be turned on gradually during the Firefox version 66 release cycle, so some users may not see it" --maybe that's the reason? unsure.gif
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
JeffLeites
post Mar 28 2019, 01:08 PM
Post #5





Group: Members
Posts: 9
Joined: 21-September 13
Member No.: 19,767



Quit looking! I found it! biggrin.gif Just took the right words in Google. The FF browser on my Desktop was set to block Autoplay. I didn't know that feature existed. If it's set to block Autoplay, an icon to that effect is shown to the right of the i in the URL area. I just had to go to the Privacy and Security option - Permissions and uncheck "Block websites from automatically playing sound". I guess IE has a similar setting. Then there's Chrome, but that's a whole different ball game.

Thanks for your assistance.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 17th October 2019 - 06:39 PM