The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> HTML style does not work in Outlook
webmastermoya
post Nov 4 2018, 11:56 AM
Post #1





Group: Members
Posts: 4
Joined: 4-November 18
Member No.: 26,741



Hi guys!
Do you know why this html code looks different in Chrome browser and Microsoft Outlook Email Application?

<!DOCTYPE html>
<html>
<body>

<table>
<tr>
<td style="padding-bottom: 5px; color: #F7751F; font-size: 16px; font-family: Raleway,Arial, Helvetica, sans-serif; font-weight: bold;">
Santiago Moyano</td>
</tr>
<tr>
<td style="padding-bottom: 5px; color: #2D3A5E; font-size: 12px; font-family: Raleway,Arial, Helvetica, sans-serif; font-weight: bold;">
Director creativo</td>
</tr>
</table>

</body>
</html>


I have attached both signatures for you to see what I mean.

Thanks for your help and have a great day!!

Santiago




Attached thumbnail(s)
Attached Image
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 4 2018, 03:16 PM
Post #2


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,107
Joined: 9-August 06
Member No.: 6



Hmm. One would think all CSS enabled email clients would support font color and size...

Dunno. Do you format the whole HTML email yourself or is your sig inserted in a template? Was thinking if something else is overriding your style. On the other hand, inline style should override everything else. Anyway, you could try to add !important to those declarations. Don't really expect it to work, but it's all I can think of.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
Christian J
post Nov 4 2018, 04:02 PM
Post #3


.
********

Group: WDG Moderators
Posts: 8,010
Joined: 10-August 06
Member No.: 7



Could it be that your copy of Outlook is configured to not show all HTML/CSS in emails? At least in Thunderbird you can choose between three viewing modes: Original HTML, Simple HTML, and Plain text.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
webmastermoya
post Nov 5 2018, 07:16 AM
Post #4





Group: Members
Posts: 4
Joined: 4-November 18
Member No.: 26,741



QUOTE(Christian J @ Nov 4 2018, 04:02 PM) *

Could it be that your copy of Outlook is configured to not show all HTML/CSS in emails? At least in Thunderbird you can choose between three viewing modes: Original HTML, Simple HTML, and Plain text.


Hi Christian, thanks for your help. I have checked what you suggest and outlook does not have these 3 viewing modes, just html only. And it is checked.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
webmastermoya
post Nov 5 2018, 09:23 AM
Post #5





Group: Members
Posts: 4
Joined: 4-November 18
Member No.: 26,741



QUOTE(pandy @ Nov 4 2018, 03:16 PM) *

Hmm. One would think all CSS enabled email clients would support font color and size...

Dunno. Do you format the whole HTML email yourself or is your sig inserted in a template? Was thinking if something else is overriding your style. On the other hand, inline style should override everything else. Anyway, you could try to add !important to those declarations. Don't really expect it to work, but it's all I can think of.


Hi Pandy, thanks so much for your help.
I sove the problem. It seems that outlook tables styles overrides my signature styles. Once i pastes signature on Outlook, then right mouse button and click "merge Tables". This will duplicate signature content: one with the right style, one with the wrong style. After that, just delete wrong signature and thats it. Thans again!
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
pandy
post Nov 5 2018, 02:45 PM
Post #6


Don't like donuts. Don't do MySpace.
********

Group: WDG Moderators
Posts: 18,107
Joined: 9-August 06
Member No.: 6



Sound like I was right after all then, even if you found a better method to fix it. Probably Outlook rewrote your HTML though, rather than overtrumping it, so !important probably wouldn't have worked.
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post
webmastermoya
post Nov 6 2018, 10:42 AM
Post #7





Group: Members
Posts: 4
Joined: 4-November 18
Member No.: 26,741



QUOTE(pandy @ Nov 5 2018, 02:45 PM) *

Sound like I was right after all then, even if you found a better method to fix it. Probably Outlook rewrote your HTML though, rather than overtrumping it, so !important probably wouldn't have worked.


Yes, you are right. Thanks so much!
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 21st January 2019 - 04:47 PM