The Web Design Group

... Making the Web accessible to all.

Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Charset / Encoding / Database Issue
post Apr 2 2013, 09:48 AM
Post #1


Group: Members
Posts: 27
Joined: 7-March 11
Member No.: 14,063

I am working on an osCommerce site that was created by duplicating another osCommerce site.

I did not handle creating this duplicate site.

On the new site, there are some characters displaying incorrectly.

I have tried changing the charset meta tag declaration, however, regardless of what charset I chose, the problem was not remedied, although the characters in question always change with the charset.

Basically, the characters in question appear to be symbols created by MS Word, such as the - symbol that is auto formatted as an em hyphen, or the ... symbol which is auto formatted as well, into the condensed version where the dots are closer together.

So, I believe the person who created the original website was copying / pasting from Word, into osCommerce.

The original website was using the charset meta tag setting of ISO-8859-1 and everything appears fine.

However, I am guessing that when the website was duplicated, the database dump file may have been generated using default encoding (UTF-8).

On the duplicated site, when I open phpMyAdmin and edit an entry that contains the above mentioned symbols, they are displayed as funky symbols (screenshot attached).

edit: I tried to upload the screenshot, but it won't let me, I've tried .png, and .jpg, the file size is about 200k, says I have 4.88 MB of upload space left, don't know why it won't upload. Here is a link to the screenshot

I copied this entry's text and pasted it into Notepad++, and from the encoding menu, chose "Encode in UTF-8" which resulted in the correct text, however, if I choose "Convert to UTF-8" from the encoding menu, before selecting "Encode in UTF-8", the text is made even worse.

Since simply encoding the text in UTF-8 resulted in the correct output, I updated the meta tag charset declaration to UTF-8, which resulted in the characters in question turning into the symbol which is a black diamond shape with a question mark overlaid.

At this point, I'm not really sure how to resolve this issue as I've never come across this particular issue before.

If anyone can give me some advice, I'd greatly appreciate it.

I've done some Googling of course, but I haven't really come across anything as of yet that looks like the correct solution.

This post has been edited by digitalpurpose: Apr 2 2013, 10:01 AM
User is offlinePM
Go to the top of the page
Toggle Multi-post QuotingQuote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:


- Lo-Fi Version Time is now: 20th October 2019 - 09:21 PM